Ada kalanya server yang ada di jaringan kita perlu bisa diakses dari jaringan publik. Misalnya karena ada karyawan yang bersifat mobile dan...
Read More
Pada artikel sebelumnya kami pernah membahas tentang bagaimana cara supaya webserver local dapat diakses dari jaringan public yang terpasang di Router, artikel tersebut dapat teman-teman baca pada artikel kami yang berjudul Forwadding dengan fitur NAT
Namun bagaimana jika kita memiliki beberapa Router local kemudian baru terdapat web server atau file server dibawah Router Local tersebut? Nah pada percobaan kali ini kami mencoba untuk membuat port forwading dengan multiple Router. Topologi pada lab kami seperti berikut ini
/ip firewall nat add action=dst-nat chain=dstnat comment="Port Forwarding Web server" dst-port=80 in-interface=ether1 protocol=tcp to-addresses=192.168.88.253 to-ports=80 |
# No-IP automatic Dynamic DNS update #--------------- Change Values in this section to match your setup ------------------ # No-IP User account info :local noipuser "testmikrotik" :local noippass "testes123" # Set the hostname or label of network to be updated. # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names. # To specify multiple hosts, separate them with commas. :local noiphost "testmikrotik.ddns.net" # Change to the name of interface that gets the dynamic IP address :local inetinterface "ether 1" #------------------------------------------------------------------------------------ # No more changes need :global previousIP :if ([/interface get $inetinterface value-name=running]) do={ # Get the current IP on the interface :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address] # Strip the net mask off the IP address :for i from=( [:len $currentIP] - 1) to=0 do={ :if ( [:pick $currentIP $i] = "/") do={ :set currentIP [:pick $currentIP 0 $i] } } :if ($currentIP != $previousIP) do={ :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed" :set previousIP $currentIP # The update URL. Note the "3F" is hex for question mark (?). Required since ? is a special character in commands. :local url "http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP" :local noiphostarray :set noiphostarray [:toarray $noiphost] :foreach host in=$noiphostarray do={ :log info "No-IP: Sending update for $host" /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt") :log info "No-IP: Host $host updated on No-IP with IP $currentIP" } } else={ :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed" } } else={ :log info "No-IP: $inetinterface is not currently running, so therefore will not update." } |
Multi layer switching adalah perangkat jaringan komputer yang melakukan proses switch pada OSI layer 2 seperti jaringan biasa dan memberikan fungsi tambahan pada lapisan OSI yang lebih tinggi. MLS juga memberikan cara menyusun perangkat network switch menjadi beberapa tingkatan dikarenakan end user yang terkoneksi ke dalam suatu jaringan memiliki jumlah yang banyak, sehingga kita perlu melakukan trunking (menyambungkan switch satu dengan switch lain) antar network switch secara bertingkat.
Switch virtual interface atau SVI berguna untuk meng-izinkan kita untuk mengkonfigurasi IP Address pada interface vlan tanpa memerlukan router. dimana IP Address pada interface vlan tersebut yang nantinya digunakan oleh client sebagai gateway VLAN.VLAN adalah Virtual Local Area Network (VLAN) adalah metode untuk menciptakan jaringan-jaringan yang secara logika tersusun sendiri-sendiri. VLAN sendiri berada dalam jaringan Local Area Network (LAN), sehingga dalam jaringan (LAN) bisa terdapat satu atau lebih VLAN.
EIGRP#show running-config hostname EIGRP ip dhcp excluded-address 192.168.1.1 ! ip dhcp pool local network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 192.168.1.1 ! interface FastEthernet0/0 ip address 192.168.1.1 255.255.255.0 ! interface FastEthernet0/1 ip address 192.168.10.2 255.255.255.252 ! router eigrp 100 network 192.168.1.0 network 192.168.10.0 0.0.0.3 no auto-summary |
OSPF#show running-config !hostname OSPF! ip dhcp excluded-address 192.168.2.1 ! ip dhcp pool local network 192.168.2.0 255.255.255.0 default-router 192.168.2.1 dns-server 192.168.2.1 ! interface FastEthernet0/0 ip address 192.168.2.1 255.255.255.0 duplex auto speed auto ! interface FastEthernet0/1 ip address 192.168.20.2 255.255.255.252 duplex auto speed auto ! router ospf 200 log-adjacency-changes network 192.168.20.0 0.0.0.3 area 0 network 192.168.2.0 0.0.0.255 area 0 neighbor 192.168.20.1 ! |
BGP.A#show running-configBuilding configuration… ! hostname BGP.A ! interface FastEthernet0/0 ip address 10.10.10.1 255.255.255.252 ! interface FastEthernet0/1 ip address 192.168.10.1 255.255.255.252 ! router eigrp 100 redistribute bgp 111 metric 100000 1 1 1 1 network 192.168.10.0 0.0.0.3 auto-summary ! router bgp 111 bgp log-neighbor-changes no synchronization neighbor 10.10.10.2 remote-as 222 network 10.10.10.0 mask 255.255.255.252 redistribute eigrp 100 ! |
BGP.B#show running-config! hostname BGP.B ! interface FastEthernet0/0 ip address 10.10.10.2 255.255.255.252 ! interface FastEthernet0/1 ip address 192.168.20.1 255.255.255.252 ! router ospf 200 router-id 1.1.1.1 log-adjacency-changes redistribute bgp 222 subnets tag 32 network 192.168.20.0 0.0.0.3 area 0 neighbor 192.168.20.2 ! router bgp 222 bgp log-neighbor-changes no synchronization neighbor 10.10.10.1 remote-as 111 network 10.10.10.0 mask 255.255.255.252 redistribute ospf 200 ! |